Unable to Submit a Support Request; BitTitan Knowledge Base Inaccessible
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 08, 2018 - 10:18 PDT
Investigating
We’re currently working through a service disruption with our vendor for our ticketing system and knowledge base database. Our team is actively working to resolve this incident and we appreciate your patience.

There may be a delay in customers submitting support tickets and for BitTitan engineers accessing support tickets. At this time our URL to our knowledge base archive is inaccessible.
Posted 4 months ago. Aug 08, 2018 - 09:29 PDT
This incident affected: Zendesk.