We are experiencing an issue with outbound network connectivity from our Corporate Headquarters
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 12, 2018 - 07:01 PDT
Update
The platform is unable to generate and send emails for the following components:
MigrationWiz New account creation
MigrationWiz Password reset
DMA installation emails

The platform is now able to generate and send emails for the following components:
MigrationWiz Project statistics
Support requests created from account.bittitan.com

At this time, if you need assistance, please email the BitTitan Support team directly at Support@BitTitan.com or create a Support Request via the Support Center in your BitTitan account.
Posted 3 months ago. Jun 12, 2018 - 06:08 PDT
Update
It has been identified that this issue is affecting our platform's ability to generate and send emails.

This is affecting the following components:
New account creation emails
Password reset emails
DMA installation emails
Project statistics emails
Support requests created from account.bittitan.com

At this time, if you need assistance, please email the BitTitan Support team directly at Support@BitTitan.com
Posted 3 months ago. Jun 11, 2018 - 13:31 PDT
Investigating
Our operations team is currently investigating the issue. BitTitan services appear to be unaffected. There will be a delay regarding responses to support requests.

Your migration projects will not be affected by this issue.
Posted 3 months ago. Jun 11, 2018 - 11:25 PDT
This incident affected: MSPComplete and MigrationWiz.