BitTitan.com is not accessible
Incident Report for BitTitan
Resolved
Our developers were able to Identify this website issue and fix it.
Posted 11 months ago. Dec 04, 2017 - 00:57 PST
Update
Our Operations team is still investigating an issue which is causing our main site www.BitTitan.com to not be accessible. If you are affected by this, please attempt to navigate to https://manage.bittitan.com and login to your account.
Posted 11 months ago. Dec 03, 2017 - 23:43 PST
Investigating
Our Operations team is investigation an issue which is causing our main site www.BitTitan.com to not be accessible.
Posted 11 months ago. Dec 03, 2017 - 17:07 PST