BitTitan.com is inaccessible
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 26, 2018 - 00:10 PDT
Investigating
Our team is investigating the issue affecting access to our sites https://www.bittitan.com, https://manage.bittitan.com and https://migrationwiz.bittitan.com.
Posted 21 days ago. Oct 25, 2018 - 23:32 PDT
This incident affected: BitTitan Website, MSPComplete, and MigrationWiz.