MSPComplete and MigrationWiz are not accessible at this time.
Incident Report for BitTitan
Resolved
The issue has been resolved.
Posted 11 months ago. Feb 28, 2018 - 10:36 PST
Identified
Our development team has identified the issue and are working to mitigate the issue.
Posted 11 months ago. Feb 28, 2018 - 08:36 PST
Investigating
Currently the MSPComplete and MigrationWiz interfaces are experiencing intermittent availability. We are currently working to restore full access. Our development engineers are currently working to establish reconnection.
Posted 11 months ago. Feb 28, 2018 - 08:11 PST