Unable to Submit Support Tickets via the BitTitan portal
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 2 months ago. Dec 12, 2017 - 16:30 PST
Investigating
Our development team is investigating an issue where customers are unable to submit Support Requests to BitTitan Support.
At this time there is not an estimated time to resolution.
An alternative would be to contact BitTitan Support via chat or send an email to support@bittitan.com.
Please provide a detailed explanation of your issue and your project information.
Posted 2 months ago. Dec 12, 2017 - 09:30 PST