Logins are slow
Incident Report for BitTitan
Resolved
Login issues have been resolved.
Posted Apr 21, 2017 - 12:17 PDT
Investigating
We are currently seeing slow login and page loads. This issue is under investigation and we will notify once it has been resolved.
Posted Apr 21, 2017 - 09:55 PDT