Slow site performance

Incident Report for BitTitan

Resolved

This incident is now resolved.
Posted May 05, 2021 - 15:47 PDT

Update

This incident is now resolved.
Posted May 05, 2021 - 15:46 PDT

Update

Site performance has returned to normal. We are continuing to monitor for any further issues.
Posted May 05, 2021 - 14:08 PDT

Update

We are continuing to monitor for any further issues.
Posted May 05, 2021 - 11:48 PDT

Monitoring

We have identified the issue, and have implemented periodic manual mitigation procedures and a workaround in order to eliminate the impact of service degradations.
Posted May 05, 2021 - 08:30 PDT

Investigating

We have identified the issue, and have implemented periodic manual mitigation procedures and a workaround in order to eliminate the impact of service degradations.
Posted May 05, 2021 - 08:29 PDT
This incident affected: BitTitan Website and MigrationWiz.