Email Sent from our System are not Being Received
Incident Report for BitTitan
Resolved
The email issue has been resolved.
Posted 5 months ago. May 04, 2019 - 18:36 PDT
Investigating
Our team is investigating an issue that is preventing emails sent from our systems from being delivered. We expect the issue to be resolved this evening, if not sooner, and will provide an update once resolved.
Posted 5 months ago. May 04, 2019 - 11:04 PDT
This incident affected: BitTitan Website, MSPComplete, MigrationWiz, and DeploymentPro.