BitTitan Help Center is inaccessible

Incident Report for BitTitan

Resolved

This incident has been resolved.
Posted Jan 16, 2020 - 15:48 PST

Update

This incident has been resolved.
Posted Jan 16, 2020 - 15:48 PST

Investigating

We are currently investigating reports of the BitTitan Help Center being inaccessible. The ability to read published content and submit tickets may be impacted. Ticket responses may be delayed as well.
Posted Jan 16, 2020 - 15:30 PST
This incident affected: Community Site and Zendesk.