Outbound System Emails are Being Processed Slowly
Incident Report for BitTitan
Resolved
The email sending issue has been resolved. Mail sending is back to normal.
Posted 2 months ago. May 07, 2019 - 23:09 PDT
Update
The email sending issue has been resolved. Mail sending is back to normal.
Posted 2 months ago. May 07, 2019 - 23:04 PDT
Monitoring
Our team is aware of the issue of outbound system emails being processed slowly from our servers.
A workaround has been implemented to mitigate the situation. We are continuing to monitor these servers.
Posted 2 months ago. May 07, 2019 - 08:43 PDT
This incident affected: MSPComplete, MigrationWiz, and DeploymentPro.