BitTitan sites are inaccessible
Incident Report for BitTitan
Resolved
Our engineering teams have resolved this issue. All systems are currently operational.
Posted Jan 31, 2020 - 11:59 PST
Monitoring
Services have been restored; our teams are currently monitoring the situation.
Posted Jan 31, 2020 - 10:52 PST
Investigating
Our team is investigating the issue that is preventing access to BitTitan sites.
Posted Jan 31, 2020 - 10:17 PST
This incident affected: BitTitan Website, MSPComplete, MigrationWiz, and DeploymentPro.