BitTitan.de site unavailable
Incident Report for BitTitan
Resolved
This incident is now resolved.
Posted May 20, 2020 - 17:29 PDT
Monitoring
Our teams have identified the cause of this incident, and have implemented mitigation steps. We are actively monitoring to verify this incident is resolved.
Posted May 20, 2020 - 17:02 PDT
Investigating
We have reports of availability being impacted for our BitTitan.de site at this time. Our teams are actively investigating the cause so mitigation steps can be implemented. Please note this does not affect MigrationWiz, MSPComplete, or DeploymentPro, and no other sites are impacted. You may use the following link to login directly to our services in the BitTitan.de system:

https://www.bittitan.de/account/login
Posted May 20, 2020 - 16:51 PDT
This incident affected: BitTitan Website.