BitTitan sites are inaccessible

Incident Report for BitTitan

Resolved

Our engineering teams have resolved this issue. Submitted jobs were not affected. All systems are currently operational.
Posted Oct 22, 2019 - 21:43 PDT

Investigating

Our team is investigating the issue that is preventing access to BitTitan sites.
Posted Oct 22, 2019 - 18:07 PDT
This incident affected: BitTitan Website, MSPComplete, MigrationWiz, and DeploymentPro.