Access Denied - UPDATE

Incident Report for BitTitan

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 09:42 PST

Monitoring

While the earlier issues have been resolved, customers who reset their password today will need to reset it again.
For customers who did not update their password today, their previous password should now work.
Posted Dec 05, 2025 - 09:53 PST
This incident affected: MigrationWiz.