Support Portal is not reachable from the help Center
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted Feb 20, 2023 - 20:50 PST
Update
This issue stands resolved now. We are extremely sorry for the inconvenience caused during this period and thank you for your patience and kind cooperation.
Posted Feb 20, 2023 - 12:33 PST
Update
Our teams are actively working on getting this issue resolved.

Meanwhile, to create a new support incident, please email our support team at Support@migrationwiz.com
Posted Feb 16, 2023 - 01:52 PST
Update
While this issue is being actively worked upon to get fixed by our engineering teams, please drop an email to Support@migrationwiz.com for creating the support tickets
Posted Feb 15, 2023 - 14:30 PST
Update
While this issue is being actively worked upon to get fixed by our engineering teams, please drop an email to Support@migrationwiz.com for creating the support tickets
Posted Feb 15, 2023 - 14:30 PST
Update
While this issue is being actively worked upon to get fixed by our engineering teams, please drop an email to Support@migrationwiz.com for creating the support tickets
Posted Feb 15, 2023 - 13:30 PST
Update
We are continuing to investigate this issue, will keep posting with further updates as we learn more.

Meanwhile, to create a new support incidents please email our support team at Support@migrationwiz.com
Posted Feb 15, 2023 - 10:47 PST
Investigating
Support Portal is currently not accessible from the Help Center (https://help.bittitan.com/hc/en-us/requests/new)
Customers are not able to access the Support Portal in order to create new tickets and check the status of existing tickets.

The issue is currently being investigated and we will be posting updates as we learn more.

At this time, new support incidents can be opened by emailing support at Support@migrationwiz.com
Posted Feb 15, 2023 - 07:36 PST
This incident affected: BitTitan Website.