Support tickets are not being created from the Help Center form
Incident Report for BitTitan
Resolved
The issue has been resolved and the Help Center form is now functioning correctly.
Customers can create the tickets through Help Center now.
Posted Sep 06, 2023 - 05:20 PDT
Identified
The issue has been identified and fix is being implemented. Meanwhile, please submit the support ticket via email to support@bittitan.com
Posted Sep 06, 2023 - 01:48 PDT
Investigating
Customers are not able to create new tickets using the form from help.bittitan.com
Customer can reach support by emailing support@migrationwiz.com or support@bittitan.com

Our teams are currently working on getting the Help Center form back online
Posted Sep 05, 2023 - 14:54 PDT
This incident affected: Zendesk.