Email Sent from our System are not Being Received
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 23 days ago. Mar 26, 2019 - 08:40 PDT
Identified
We are currently experiencing degradation with our email service.
You may experience delayed notification mail or report during this period.
Our team is currently working to resolve the issue
Posted 24 days ago. Mar 26, 2019 - 00:49 PDT
This incident affected: BitTitan Website and MigrationWiz.