Migrations submitted in United States data-center stuck in Submitted status
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 19:08 PDT
Identified
Our teams have identified the cause of this incident, and are working towards mitigation steps.
Posted Apr 10, 2020 - 18:27 PDT
Investigating
We have reports of availability being impacted for United States datacenters at this time. Our teams are actively investigating the cause so mitigation steps can be implemented.
Posted Apr 10, 2020 - 17:41 PDT
This incident affected: MigrationWiz.