Modernized Microsoft 365 Authentication for Better Security & Ease of Use (Update)

Incident Report for BitTitan

Resolved

This incident is now resolved.
Posted Apr 29, 2026 - 06:27 PDT

Identified

We have upgraded our Microsoft 365 authentication to Microsoft’s modern identity platform (v2) to improve security, reliability, and configuration experience.

Known Issues:

OneDrive Migrations (Delegate App)
Customers using the Advanced Option ForceOneDriveNonGlobalAdminAuthExport=1 may experience credential failures.
This option remains functional for SharePoint-to-SharePoint migrations.

Recommendation: Remove this advanced option if possible and assign the SharePoint Administrator role to the Delegate account.
This issue is under investigation.

Tenant-to-Tenant Coexistence (Free/Busy Setup)
Organizational relationship creation is currently failing for coexistence projects.

Workaround: If free/busy is not required, create a standard mailbox project without coexistence.
We are actively investigating and will provide updates as available.
Posted Feb 13, 2026 - 13:09 PST
This incident affected: MigrationWiz and MigrationWiz DE.