.DE Environment - Unable to Create New Customers in MSPComplete & View Existing Projects in MigrationWiz
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted about 2 months ago. May 31, 2019 - 06:10 PDT
Investigating
Our team is investigating the issue that is causing MSPComplete and MigrationWiz to not allow the creation of new Customers and to view existing projects in existing Customers, respectively.
This is only affecting the .DE environment - https://www.bittitan.de/account/login. The status page will be updated once further information is made available.
Posted about 2 months ago. May 31, 2019 - 05:31 PDT
This incident affected: MSPComplete and MigrationWiz.