Email Sent from our System are not Being Received
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 28 days ago. Feb 22, 2019 - 08:13 PST
Investigating
Our team is investigating the issue that is preventing automated emails from being delivered. This issue is primarily affecting, but not limited to, users attempting to account passwords and create new accounts.
Posted 28 days ago. Feb 22, 2019 - 07:00 PST
This incident affected: BitTitan Website and MigrationWiz.