Unable to Submit a Support Request
Incident Report for BitTitan
Resolved
This incident has been resolved. Support tickets can now be created through the automated form.
Posted 4 months ago. Jun 04, 2019 - 09:06 PDT
Investigating
Our team is investigating the issue that is preventing the submission of a Support request from our contact page. To request assistance, email the Support team directly at Support@BitTitan.com.
Posted 4 months ago. Jun 04, 2019 - 05:57 PDT
This incident affected: Community Site.