Slow site performance
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted Dec 09, 2021 - 09:27 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 09, 2021 - 01:54 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2021 - 18:47 PST
Monitoring
Mitigation steps have been implemented, and our teams are actively monitoring to verify this incident is resolved.
Posted Dec 08, 2021 - 16:15 PST
Investigating
We have reports of performance/availability being impacted for MigrationWiz and BitTitan.com at this time. This may also cause submitted migrations to take longer than usual to get started Our teams are actively investigating the cause so mitigation steps can be implemented.
Posted Dec 08, 2021 - 12:29 PST
This incident affected: MSPComplete and MigrationWiz.