BitTitan Help Center assessibility

Incident Report for BitTitan

Resolved

This incident is now resolved.
Posted 4 years ago. May 30, 2021 - 23:39 PDT

Monitoring

Mitigation steps have been implemented, and our teams are actively monitoring to verify this incident is resolved.
Posted 4 years ago. May 30, 2021 - 22:34 PDT

Identified

The issue have been identified as a SSL certificate issue. We are working to get this resolved. As a work around, when accessing help.bittitan.com, please click on "Advanced" button in the page encountered and then on the link that is displayed to proceed to the desired page.
Posted 4 years ago. May 30, 2021 - 21:07 PDT

Investigating

We are currently investigating reports of the BitTitan Help Center being inaccessible.
Posted 4 years ago. May 30, 2021 - 20:48 PDT
This incident affected: Community Site and Zendesk.