BitTitan sites are inaccessible
Incident Report for BitTitan
Resolved
Our engineering teams have resolved this issue. All systems are currently operational.
Posted 4 months ago. May 16, 2019 - 08:11 PDT
Investigating
Our team is investigating the issue that is preventing access to BitTitan sites.
Posted 4 months ago. May 16, 2019 - 07:32 PDT
This incident affected: MSPComplete and MigrationWiz.