Site Spoofing Attempt
Incident Report for BitTitan
Resolved
This issue has been addressed. As a reminder, please use only BitTitan.com for any login purposes.
Posted Jan 10, 2021 - 17:01 PST
Investigating
Alert: BitTitan discovered the existence of an illegal website that mimics our website and could be used by threat actors to steal credentials as part of a broader phishing scheme. Please DO NOT enter your BitTitan credentials into any website other than our official website (https://bittitan.com). We are not aware of any breaches in our environment at this time.
Posted Jan 08, 2021 - 16:39 PST
This incident affected: BitTitan Website.