www.bittitan.com will be undergoing maintenance today between 2:30 PM to 3 PM PST
Incident Report for BitTitan
Resolved
Maintenance has been completed.
Posted Feb 05, 2020 - 14:57 PST
Monitoring
There will be no impact to migrations or other services.
Posted Feb 05, 2020 - 11:23 PST
This incident affected: BitTitan Website.