BitTitan.com is experiencing issues
Incident Report for BitTitan
Resolved
No further reports have been received nor have we found any further issues. This issue is now considered resolved.
Posted Oct 23, 2019 - 15:21 PDT
Monitoring
BitTitan has become aware of reports regarding the availability of our website, BitTitan.com. Service is currently available and we are monitoring the situation at this time. No other services have been affected.
Posted Oct 23, 2019 - 14:06 PDT
This incident affected: BitTitan Website.