Slow Migration Speeds

Incident Report for BitTitan

Resolved

This issue now stands resolved. We regret for the inconvenience you might had because of this and thanks you for your kind cooperation.
Posted May 02, 2023 - 15:32 PDT

Investigating

Some MigrationWiz customers may be experiencing slow migration speeds. Our teams are working hard to identify the cause and resolve. We will keep you updated as we have more details.

ETA for next Update : 2Hrs
Posted May 02, 2023 - 13:13 PDT
This incident affected: MigrationWiz.