Our ticket creation and responses may be slower than normal or fail.
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 5 days ago. Sep 14, 2019 - 10:08 PDT
Investigating
Our support ticketing system vendor is experiencing an outage. Our ticket creation and responses may be slower than normal or fail.
Posted 6 days ago. Sep 13, 2019 - 09:05 PDT
This incident affected: Community Site and Zendesk.