Slow site performance
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted May 04, 2021 - 14:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 12:38 PDT
Identified
Our teams have identified the cause of this incident, and are working towards mitigation steps.
Posted May 04, 2021 - 10:29 PDT
Update
We are continuing to investigate this issue.
Posted May 04, 2021 - 10:28 PDT
Investigating
We have reports of performance/availability being impacted for MigrationWiz and BitTitan.com at this time. Our teams are actively investigating the cause so mitigation steps can be implemented.
Posted May 04, 2021 - 08:47 PDT
This incident affected: BitTitan Website and MigrationWiz.