Support Chat Unavailable
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 10, 2018 - 10:50 PDT
Update
We are continuing to investigate this issue.
Posted 9 days ago. Aug 10, 2018 - 06:34 PDT
Investigating
LiveChat with BitTitan Technical Support is currently unavailable. The software vendor for the chat service is experiencing a service issue at this time.
Posted 9 days ago. Aug 10, 2018 - 06:33 PDT
This incident affected: Zendesk.