Cannot install Device Management Agent
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 22, 2017 - 09:28 PST
Investigating
We are aware and investigating the issue about not being able to install the Device Management Agent.
The error on the webpage reads: "An Error Has Occured
Our team has been notified & is working to resolve this issue"

We will provide updates on this matter.
Posted 11 months ago. Nov 22, 2017 - 03:44 PST