Unable to submit a Support request
Incident Report for BitTitan
Resolved
All affected items have been tested and the issue is resolved.
Posted 3 months ago. Apr 18, 2018 - 10:18 PDT
Update
We have been informed by our Operations team that this issue is affecting the following components:

Support Requests
New Account Registrations
Password Resets
Purchases
Device Management Agent (DMA) Installation emails
Project Statistics
Posted 3 months ago. Apr 17, 2018 - 18:04 PDT
Investigating
Our Operations team is investigating an issue that is preventing the ability to submit a Support request from our contact page. If you need assistance at this time, please email the Support team directly at Support@BitTitan.com
Posted 3 months ago. Apr 17, 2018 - 16:26 PDT