Unable to submit a Support request
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 27, 2018 - 14:59 PST
Investigating
Our Operations team is investigating an issue that is preventing users from submitting a Support request from https://account.bittitan.com/contact.

At this time, please email Support@BitTitan.com to receive assistance with our product.
Posted 8 months ago. Feb 27, 2018 - 12:35 PST