Unable to apply subscriptions to users
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 20, 2017 - 21:53 PDT
Investigating
Our development team is investigating an issue that is preventing the ability to apply subscriptions to users. We do not have an ETA at this time as to when this problem will be resolved.
Posted about 1 year ago. Sep 20, 2017 - 16:45 PDT