Degraded performance for MSPComplete and MigrationWiz
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted Apr 25, 2017 - 14:07 PDT
Identified
Our Operations team has identified the issue that is affecting the performance of our MSPComplete and MigrationWiz platforms. We are in the process of rectifying the problem.
Posted Apr 23, 2017 - 22:23 PDT