MigrationWiz Inaccessible
Incident Report for BitTitan
Resolved
Our developers have implemented a fix, and all resources should now be accessible.
Posted 6 months ago. May 30, 2018 - 09:46 PDT
Investigating
MigrationWiz is currently inaccessible, and your browser will be redirected to a login page if attempting to access that product. Our developers have been notified are working to resolve the issue.
Posted 6 months ago. May 30, 2018 - 08:56 PDT
This incident affected: MigrationWiz.