Manage.bittitan.com is fully functional. We continue to monitor for any issues.
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 9 days ago. Jul 09, 2018 - 17:37 PDT
Update
Our restore is complete and we are seeing all previous migrations updating to the their current status.

Thank you for your patience.
Posted 10 days ago. Jul 08, 2018 - 13:02 PDT
Update
As part of the continued monitoring of this issue, we are restoring further information that will degrade some of the MigrationWiz submission times. You may see migration items stay in a queued state for 1-2 hours at this time.

The restore process has an ETA of 2 hours to completion, and at that time migrations will be processed in the order they were submitted.
Posted 10 days ago. Jul 08, 2018 - 11:15 PDT
Update
We are continuing to monitor for any further issues.
Posted 11 days ago. Jul 06, 2018 - 21:13 PDT
Update
We are restoring accounts impacted by the outage on July 2nd.

If you recently registered for an account and cannot access it, first try re-registering with the same email address. If the system indicates you are already registered, contact sales@bittitan.com.

If you purchased licenses on July 1st or 2nd and are unable to access them, contact support@bittitan.com.

If you are a distributor and have questions about a purchase, contact disti@bittitan.com.
Posted 12 days ago. Jul 06, 2018 - 18:12 PDT
Update
We are continuing to monitor for any further issues.
Posted 12 days ago. Jul 06, 2018 - 07:22 PDT
Update
The MSPComplete and MigrationWiz services have now been restored. We are actively monitoring the systems to ensure service integrity at this time.

There are some items impacted:

1. Projects and line items in MigrationWiz may need to be recreated if they are no longer available.

2. Items created in MSPComplete after 07/01/2018 19:00 Pacific Time may need to be recreated

3. Deleted items after 07/01/2018 19:00 Pacific Time may reappear, these can be deleted again if necessary.

4. Items that were in mid migration will not have duplicates on another pass. The watermark system was not affected, and will continue to prevent duplicates on subsequent passes.

5. Licenses purchased on July 1st and July 2nd may take a couple of hours to be restored.

We sincerely appreciate your patience while the services were restored.
Posted 15 days ago. Jul 03, 2018 - 09:11 PDT
Monitoring
The MSPComplete and MigrationWiz services have now been restored. We are actively monitoring the systems to ensure service integrity at this time

There are some items impacted:

1. Projects and line items in MigrationWiz may need to be recreated if they are no longer available.

2. Items created in MSPComplete after 07/01/2018 19:00 Pacific Time may need to be recreated

3. Deleted items after 07/01/2018 19:00 Pacific Time may reappear, these can be deleted again if necessary.

We sincerely appreciate your patience while the services were restored.
Posted 15 days ago. Jul 03, 2018 - 08:31 PDT
Update
We are continuing to work on a fix for this issue.
Posted 15 days ago. Jul 03, 2018 - 05:29 PDT
Update
Our operations team has identified the problem to be with our primary database. Service was temporarily restored, however, to bring our database to a current state they will be taken offline again. This will result in our site being inaccessible.

07/03/2018 05:15am PDT update: Due to anomalies in the Azure Environment, the database restore is still in process. Microsoft is currently attempting to address the issue. There is no ETA to service restoration at this time.
Posted 15 days ago. Jul 03, 2018 - 05:22 PDT
Update
Our operations team has identified the problem to be with our primary database. Service was temporarily restored, however, to bring our database to a current state they will be taken offline again. This will result in our site being inaccessible.

10:30pm PDT update: Because of a failure in our database restore, we are now estimating that the total service restoration will be 7-8 hours.
Posted 15 days ago. Jul 02, 2018 - 22:42 PDT
Identified
Our operations team has identified the problem to be with our primary database. Service was temporarily restored, however, to bring our database to a current state they will be taken offline again. This will result in our site being inaccessible.

As of now (8pm PDT), we are estimating that total service restoration will be complete in the next 3-4 hours.
Posted 15 days ago. Jul 02, 2018 - 20:11 PDT
Update
Our operations team identified the problem to be with our primary database. Service was temporarily restored, however, to bring our database to a current state they will be taken offline again. This will result in our site being inaccessible.

We are estimating that total service restoration will be complete in the next 3-5 hours.
Posted 16 days ago. Jul 02, 2018 - 15:49 PDT
Update
Our operations team is still working to restore access to our site. At this time, there is no ETA on when service will be restored.
Posted 16 days ago. Jul 02, 2018 - 14:30 PDT
Investigating
Our development is currently investigating the issue.
At this time, there is no estimated time to resolution.
Posted 16 days ago. Jul 02, 2018 - 11:05 PDT
This incident affected: MSPComplete, MigrationWiz, and Deployment Pro.