Unable to apply subscriptions to users
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 11, 2017 - 17:21 PDT
Investigating
Our development team is investigating an issue that is preventing the ability to apply subscriptions to users.
Posted 7 months ago. Oct 11, 2017 - 16:56 PDT