www.bittitan.com will be down for 30 minutes for brief maintenance window
Incident Report for BitTitan
Resolved
The maintenance is completed.
Posted 3 months ago. Apr 20, 2018 - 12:41 PDT
Investigating
A brief maintenance will be performed. There should be no impact migrations or other services.
Posted 3 months ago. Apr 20, 2018 - 12:07 PDT