We are experiencing an issue with outbound network connectivity from our Corporate Headquarters
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 03, 2018 - 11:02 PST
Investigating
Our operations team is currently investigating the issue. BitTitan services appear to be unaffected. There will be a delay regarding responses to support requests.
Posted 7 months ago. Jan 03, 2018 - 09:02 PST