Emails sent from our system are not being received
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 20, 2018 - 14:08 PDT
Monitoring
Our operation team has upgraded our email system to fix the email delivery issues. We will continue to monitor to confirm full resolution.
Posted 10 months ago. Apr 13, 2018 - 10:47 PDT
Investigating
Our Development team is investigating an issue that is preventing automated emails to be delivered. This issue is primarily affecting emails sent to Office 365 mailboxes.
Posted 11 months ago. Mar 27, 2018 - 12:35 PDT