BitTitan.com and manage.bittitan.com are inaccessible
Incident Report for BitTitan
Resolved
The issue has been resolved. All operations are now back to normal.
Posted 10 months ago. Feb 26, 2018 - 01:36 PST
Identified
Our team has identified the issue. We are actively working on the fix.
Posted 10 months ago. Feb 26, 2018 - 00:45 PST
Investigating
Our development team is currently investigating on the cause
Posted 10 months ago. Feb 25, 2018 - 23:41 PST