Unable to submit a Support request
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 26, 2018 - 14:32 PDT
Monitoring
Our engineers have remediated the issue and are continuing to monitor the system.
Posted 5 months ago. Apr 25, 2018 - 07:22 PDT
Investigating
Our Operations team is investigating an issue that is preventing the ability to submit a Support request from our contact page. If you need assistance at this time, please email the Support team directly at Support@BitTitan.com
Posted 5 months ago. Apr 24, 2018 - 15:22 PDT