Unable to Generate Email from any BitTitan Site
Incident Report for BitTitan
Resolved
Our development team has updated the platform so that email functionality is restored.
Posted about 1 month ago. Mar 19, 2018 - 05:35 PDT
Investigating
Currently, any form or process that generates an email is failing. This is preventing items such as Account Registrationg, Password Reset, Agent Install Emails, etc from being completed. Our Development and Operations team is currently investigating, and an update will be provided once the cause is identified.
Posted about 1 month ago. Mar 18, 2018 - 07:28 PDT