BitTitan.com and manage.bittitan.com are inaccessible
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 05, 2018 - 22:56 PDT
Investigating
Our developers are investigating the current issue that is affecting access to our sites.
We do not have an ETA at this moment. However, we will provide updates as soon as available.
Posted 3 months ago. Apr 05, 2018 - 22:47 PDT