Intermittent website access issues
Incident Report for BitTitan
Resolved
BitTitan Websites intermittent resource issue has been resolved. All BitTitan websites should now be accessible.
Posted about 1 month ago. Mar 18, 2018 - 13:36 PDT
Monitoring
Our teams have identified the source of the issue and have made changes to alleviate. Access should now be available for all sites. We will continue to monitor the state of the applications.
Posted about 1 month ago. Mar 18, 2018 - 10:47 PDT
Investigating
BitTitan Websites are currently experiencing an intermittent resource resolution issue. Our development team is currently investigating, and an update will be posted once the cause is identified.
Posted about 1 month ago. Mar 18, 2018 - 09:01 PDT