Email Sent from our System are not Being Received
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 30, 2018 - 09:37 PST
Investigating
Our team is investigating the issue that is causing the failure of any form or process that generates an email message. This situation prevents actions like Account Registration, Password Reset, Agent Install Emails, etc., from completing correctly.
Posted 14 days ago. Nov 29, 2018 - 10:02 PST
This incident affected: BitTitan Website, MSPComplete, MigrationWiz, and DeploymentPro.